Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Loytec Lvis 3e100 и Lonmaker
Диалог специалистов АВОК > ОБЩИЙ ФОРУМ > Автоматизация систем > LonWorks
ganz72
Всем добрый день.
Есть интересный "зоопарк" с вентиляцией на Regin, управлением освещением и теплыми полами на Segnetics, 2-мя панелями LVis для дистанционного управления и шлюзом Xenta 913 от SE/TAC. Почему так - к вопросу отношения не имеет, это всего лишь предисловие.
Проблема: xif-файл созданный LVis Configurator не грузится в LM 3.1 Нажмите для просмотра прикрепленного файла
Не могу понять, что за параметр не устраивает LM (ошибка #29).
Создаю файл с 5-ю переменными - загружается, связывается со шлюзом, транслируется в Modbus, свет управляется. Bingo!
Когда добавляю еще одну или несколько переменных - получаю то, что на принтскрине.
Xif-файлы от других устройств подгружаются нормально. (На принтскрине виден FB от xenta 913 на 200 переменных)
Для LVis, часом, не платный софт какой-нить нужен?
Готов проверить любые идеи. Направьте, пожалуйста.
Scribe
Доброго времени суток!

Цитата(ganz72 @ 7.1.2014, 11:36) *
... Для LVis, часом, не платный софт какой-нить нужен? ...
Для L-Vis - неплатный, точно.

IMHO:
- экспортированный L-Vis XIF с добавленными статическими переменными в функциональных блоках используется в случае тиражирования L-Vis Проекта
- RTFM по L-Vis:
--- использование L-Vis Plug-In
--- разница между статическими и динамическими переменными в функциональных блоках

--
Успехов!
ganz72
Цитата(Scribe @ 7.1.2014, 20:52) *
IMHO:
- экспортированный L-Vis XIF с добавленными статическими переменными в функциональных блоках используется в случае тиражирования L-Vis Проекта
- RTFM по L-Vis:
--- использование L-Vis Plug-In
--- разница между статическими и динамическими переменными в функциональных блоках


Спасибо за оперативность.
С L-Vis Plug-In проблем вроде нет (а что может быть с ним?).
Переменные только статические.
По первому пункту Вашего ответа нельзя ли уточнить, какие ограничения или особенности при тиражировании? Не нашел в мануале.
Да, может быть, проблема с заменой проекта в панели, соответственно и xif кривой какой-то создается? Не надо ли ее ресетить в заводские настройки перед заливкой другого проекта?
Scribe
удивительная куча вопросов, без дополнительной информации
Chabol
Приложите проект L-Vis, так легче будет помочь.
ganz72
Сам проект.
Chabol
Какой-то глюк в самом проекте.
Несколько раз открывал его и в таблице переменных наблюдал "NV Type" как UnknownType.
Повторное открытие уже отображало заданные Вами типы.

Генерирование XIF давало в ЛонМейкере ту же ошибку, о которой Вы пишете.
Сделал пару танцев с бубном (в Datapoint dialog выделил все переменные и Sync Datapoint Name, Reorder NV indices, Renumber Datapoints - не стал разбираться что именно помогло, можете сами попробовать пошагово) - помогло. XIF теперь нормально воспринимается ЛонМейкером.
Программу и ксиф прилагаю.


Для удобства работы рекомендую в "Data Point selection and management" (таблице где определяете переменные) сгруппировать переменные по функциональным блокам по каким-то характеристикам. У вас все определены в L-Vis[0] и оперировать одним блоком с 158 переменными не очень удобно. Выделив в таблице группу переменных их можно засунуть в любой из L-Vis[0...7] не оказав влияние на связи переменных внутри проекта.
ganz72
Спасибо.
Сегодня вечером попробую подгрузить.
В противном случае заново писать придется, наверное.
По поводу разбить FB уже подумал, но умная мысля приходит как обычно.
ganz72
Иду по граблям дальше.
XIF сгенерировался, спасибо, но легче не стало.
L-Vis не комиссится. Появилось вот это:
Нажмите для просмотра прикрепленного файла
Дальше делаю, как описано в NS Error Code Network Services
1. Delete the device and the device template, and re-add/commission the device again using the
correct XIF file.
Если правильно понимаю, удаляю из проекта устройство и шаблон и создаю заново. Результат тот же.
В сомнение вводит замечание о корректном XIF. Что имеется ввиду? У меня XIF, загруженный в панель и в LM один и тот же. Program ID тоже совпадает.
Подскажите, что сделать?
Chabol
Удалите все темплейты касающие L-Vis (в т.ч. и те, которые прописались после инсталяции LVIS Configurator).
Делаеся это через верхнее меню Visiо, где LonMaker. А потом подключите через ксиф или в онлайне с устройства (так будет вернее, т.к. есть гарантия что считывается прямо с железяки и будет совпадать ID).
По описаню, вроде делаете все верно.
Кстати, приложенны мной ксиф подключался нормально. Комисить не смог, т.к. LVIS нет под рукой.
Как вариант пробуйте в новом чистом проекте Лонмейкера подключить вариант, который не работает.
ganz72
Спасибо.
Буду пытаться дальше.
ganz72
По результатам. Работает. Переустановил LM, затем XIF-файл прямо с LVis после его загрузки в LM скачал . Пока еще не привязывал Corrigo.
Спасибо за помощь.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Форум IP.Board © 2001-2019 IPS, Inc.